Regarding GTK+ 3.0

Some shit is flowing around about breaking compatibility for GTK+ 3.0. Imendio should stay clear of library code if that’s what they want to do. Thankfully, there are people who do get it, like Miguel de Icaza and Morten Welinder.

The hard part is keeping compatibility (something that even Apple doesn’t do right in between major OSX versions), and it seems that especially in the FOSS world, no one wants to do the hard things. In the world of Linux, coders should realize that it all comes down to “compatibility, compatibility, compatibility…” and not “developers, developers, developers…”.

Comments are closed as this blog post is now archived.

Lines, paragraphs break automatically. HTML allowed: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>

The URI to TrackBack this blog entry is this. And here is the RSS 2.0 for comments on this post.