My phone died

Awwh… My QTek 9100, which was serving as my main phone for about 9 months, just died. Or so it seems so. Basically, this is what happened: I received the Nokia 6288 for a review yesterday and I needed to use my SIM. So, I turned off the 9100, removed the SIM card and I replaced its battery. Then, I connected it to the charger while turned off (all other phones can recharge when OFF, they just boot a part of their OS to do so). I think this was the part that killed it. Nothing works now, I tried to reset it, hard reset it, change chargers, nothing brings it back to life. It doesn’t make a peep and no lights are turning ON at all. And I don’t want to send it to support, because if they indeed fix it, all my passwords are there.

I think that the E61 will take now the duties of my main phone.

UPDATE: The battery was completely discharged. I tried yet another usb charger (slightly different voltage), and what do you know, the damn thing turned back ON and now it’s charging!

1 Comment »

Vassilis 'vasper' Perantzakis wrote on January 26th, 2007 at 9:39 AM PST:

(Note to self: Always start reading from the UPDATE)…

Eugenia, I use the same phone and I was terrified while reading the post… :-)


Comments are closed as this blog post is now archived.

Lines, paragraphs break automatically. HTML allowed: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>

The URI to TrackBack this blog entry is this. And here is the RSS 2.0 for comments on this post.